Internet Explorer 9 / Firefox 4 – Facebook Flash Issues

Are you having problems with Facebook games on Facebook using IE9 or Firefox 4?

Here is what I found. These guys (Microsoft and Mozilla) got something right in their browsers; giving the browsers direct access to the graphics card.

So this is really good most of the time, pages will act more responsive.

And now…

Adobe has to get with it, Flash games aren’t displaying properly with the new browsers.

The solution in IE9 is to go into Internet Options (click on the gear icon on the right side of the window) > Advanced Tab. Then check the tab the Graphics Acceleration option to use software rendering.

In Firefox 4, go into Options > Advanced > General tab. Then uncheck the “Use hardware acceleration when available” box.

These solutions will allow the games to work a little better, but general web pages might not be as responsive.

I have an additional information on this topic here.

Subscribe to this blog if you like this tip.

Advertisements

13 thoughts on “Internet Explorer 9 / Firefox 4 – Facebook Flash Issues

  1. Excellent article and easy to understand explanation. How do I go about getting permission to post part of the article in my upcoming newsletter? Giving proper credit to you the author and link to the site would not be a problem.

  2. Intersting stuff. I have a 64-bit system, Windows 7. Everything has been fine for a couple of years up til now. Recently, NONE of my FB displays correctly excepting a few bars and indeces across the top and sides of the page. Also, it can no longer load in Gmail. I have now switched to Mozilla to use the internet.
    The really weird part? – My wife and I share the same computer under different accounts. She continues to use IE without an issue on her “side” of the computer. I tried resetting IE to defaults – still no improvement.

    • Did you install/update anything before the issues started? It sounds like it could be an issue with your JavaScript settings. Make sure you have JavaScript enabled. Also sometimes toolbars are the cause of many issues. If you disable/remove them, it would be a good troubleshooting step.

      • Well, stranger things have happened…� I tried your fixes – nothing had been changed or otherwise messed up that I could find.� However, in looking a bit further, I found that IE 10 had been released.� I installed it and *poof* problem solved. One other noteworthy part of this whole thing was that this laptop comes with fingerprint swiping for accessibility.� I’d also lost my prompting to swipe my finger to get into my various accounts and what-not.� THAT feature is still not working… I’m thinking it must somehow tie into this whole thing. Thank for taking the time to explore this with me. Brent

        ________________________________

Have an opinion? Leave an opinion!

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s